summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuis Felipe Strano Moraes <luis.strano@gmail.com>2022-11-10 15:57:05 -0800
committerMarge Bot <emma+marge@anholt.net>2022-11-11 07:35:27 +0000
commitd983827a62c77713452a9e420fd20ed39c68ef2c (patch)
tree45ecd6569796ba0883c302bd758b5cd3e254a6fd /meson.build
parent8e677bc1e19cf317720649fc0548f74441a2d6eb (diff)
downloadmesa-d983827a62c77713452a9e420fd20ed39c68ef2c.tar.gz
meson: only enable intel-clc for x86_64 builds
Reviewed-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19662>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6f7cac4c11c..77cbe5efef6 100644
--- a/meson.build
+++ b/meson.build
@@ -300,8 +300,13 @@ if with_aco_tests and not with_amd_vk
endif
with_microsoft_clc = get_option('microsoft-clc').enabled()
-with_intel_clc = get_option('intel-clc').enabled()
-with_intel_vk_rt = with_intel_vk and with_intel_clc
+if ['x86_64'].contains(host_machine.cpu_family())
+ with_intel_clc = get_option('intel-clc').enabled()
+ with_intel_vk_rt = with_intel_vk and with_intel_clc
+else
+ with_intel_clc = false
+ with_intel_vk_rt = false
+endif
with_clc = with_microsoft_clc or with_intel_clc
with_libclc = with_clc
with_spirv_to_dxil = get_option('spirv-to-dxil')