summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2022-12-20 15:17:13 -0800
committerMarge Bot <emma+marge@anholt.net>2023-01-19 16:29:03 +0000
commitca615a4f16d3a2e1c5078aee7b83556a4121116a (patch)
treea0e843b1eaf4ad8bc0e5603dd481afca689cff47 /meson.build
parent80eb78d7a4ba70e81e32d2a7bd3d6b242da6c7bd (diff)
downloadmesa-ca615a4f16d3a2e1c5078aee7b83556a4121116a.tar.gz
meson: use a feature option for gles1
Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Acked-by: Alyssa Rosenzweig <alyssa.rosenzweig@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20409>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 7 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index c91c028f0eb..bdc6bd70a7b 100644
--- a/meson.build
+++ b/meson.build
@@ -107,14 +107,6 @@ if gbm_backends_path == ''
gbm_backends_path = join_paths(get_option('prefix'), get_option('libdir'), 'gbm')
endif
-with_gles1 = get_option('gles1')
-if with_gles1 == 'true'
- with_gles1 = 'enabled'
- warning('gles1 option "true" deprecated, please use "enabled" instead.')
-elif with_gles1 == 'false'
- with_gles1 = 'disabled'
- warning('gles1 option "false" deprecated, please use "disabled" instead.')
-endif
with_gles2 = get_option('gles2')
if with_gles2 == 'true'
with_gles2 = 'enabled'
@@ -138,27 +130,27 @@ with_shared_glapi = get_option('shared-glapi') \
.disable_auto_if(host_machine.system() == 'windows') \
.allowed()
+with_gles1 = get_option('gles1') \
+ .require(with_shared_glapi, error_message : 'OpengGL ES 1.x requires shared-glapi') \
+ .require(with_opengl, error_message : 'building OpenGL ES 1.x without OpenGL is not supported.') \
+ .allowed()
+
# shared-glapi is required if at least two OpenGL APIs are being built
if not with_shared_glapi
- if ((with_gles1 == 'enabled' and with_gles2 == 'enabled') or
- (with_gles1 == 'enabled' and with_opengl) or
- (with_gles2 == 'enabled' and with_opengl))
+ if with_gles2 == 'enabled' and not with_opengl
error('shared-glapi required for building two or more of OpenGL, OpenGL ES 1.x, OpenGL ES 2.x')
endif
- with_gles1 = 'disabled'
with_gles2 = 'disabled'
endif
# We require OpenGL for OpenGL ES
if not with_opengl
- if (with_gles1 == 'enabled' or with_gles2 == 'enabled') and not with_opengl
+ if with_gles2 == 'enabled' and not with_opengl
error('building OpenGL ES without OpenGL is not supported.')
endif
- with_gles1 = 'disabled'
with_gles2 = 'disabled'
endif
-with_gles1 = with_gles1 != 'disabled'
with_gles2 = with_gles2 != 'disabled'
with_any_opengl = with_opengl or with_gles1 or with_gles2
# Only build shared_glapi if at least one OpenGL API is enabled