summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJosé Roberto de Souza <jose.souza@intel.com>2022-11-23 12:32:02 -0800
committerMarge Bot <emma+marge@anholt.net>2023-03-10 19:41:14 +0000
commitc5888bf61036e34b1853e1080926e851f265b272 (patch)
tree6c3c18030b92b48def8f641c4a743ea43d0edba4 /meson.build
parent757e2dd692b2d795042ac70527946c4abdf7d156 (diff)
downloadmesa-c5888bf61036e34b1853e1080926e851f265b272.tar.gz
build: Block build of HASVK, Crocus and i915 in non-x86 architectures
HASVK, Crocus and i915 drivers only supports integrated GPUs. Signed-off-by: José Roberto de Souza <jose.souza@intel.com> Reviewed-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/21773>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 20f919f4e46..e6801c71bc3 100644
--- a/meson.build
+++ b/meson.build
@@ -1424,6 +1424,18 @@ if get_option('intel-xe-kmd').enabled()
pre_args += '-DINTEL_XE_KMD_SUPPORTED'
endif
+if with_intel_hasvk and host_machine.cpu_family().startswith('x86') == false
+ error('Intel "hasvk" Vulkan driver requires x86 or x86_64 CPU family')
+endif
+
+if with_gallium_crocus and host_machine.cpu_family().startswith('x86') == false
+ error('Intel "crocus" Gallium driver requires x86 or x86_64 CPU family')
+endif
+
+if with_gallium_i915 and host_machine.cpu_family().startswith('x86') == false
+ error('Intel "i915" Gallium driver requires x86 or x86_64 CPU family')
+endif
+
# Determine whether or not the rt library is needed for time functions
if host_machine.system() == 'windows' or cc.has_function('clock_gettime')
dep_clock = null_dep