summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErik Faye-Lund <erik.faye-lund@collabora.com>2022-03-24 10:34:41 +0100
committerMarge Bot <emma+marge@anholt.net>2022-04-19 06:54:47 +0000
commitbe952e71a70bb6ac1afde8876e4615b287bd4089 (patch)
tree4850a0606ddf9aebc6bf6ee65675f6b39b2219f1 /meson.build
parentb27a2ba4fcb07d0d55e237f6d62c8dd69e0f1380 (diff)
downloadmesa-be952e71a70bb6ac1afde8876e4615b287bd4089.tar.gz
meson: turn on -Wno-unused-function project-wide
We generate a lot of functions without knowing if they end up being used or not. So we can't easily avoid these warnings. This fixes a bunch of warnings for me when building with Clang. Acked-by: Alyssa Rosenzweig <alyssa@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15547>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 189a5c51ec4..7d3520c17ba 100644
--- a/meson.build
+++ b/meson.build
@@ -1167,6 +1167,7 @@ else
'-fno-common',
# Clang
'-Wno-microsoft-enum-value',
+ '-Wno-unused-function',
]
_trial_cpp = [
'-Werror=return-type',