summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2022-09-06 17:32:29 +0800
committerMarge Bot <emma+marge@anholt.net>2022-10-20 03:04:56 +0000
commitb6e4aa6f31b489791dd0439344541abd014edac1 (patch)
treebb4ffe85070ea370900bf782445abdcaf195258d /meson.build
parent2f140c564f351db4348d02148c490c291325e6d8 (diff)
downloadmesa-b6e4aa6f31b489791dd0439344541abd014edac1.tar.gz
meson/mesa/wide: define WIN32_LEAN_AND_MEAN with pre_args
Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/18425>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9f7db50225f..ce2ec7a79c8 100644
--- a/meson.build
+++ b/meson.build
@@ -1617,6 +1617,10 @@ elif host_machine.system() != 'windows'
else
dep_expat = null_dep
endif
+# Predefined macros for windows
+if host_machine.system() == 'windows'
+ pre_args += '-DWIN32_LEAN_AND_MEAN' # http://msdn2.microsoft.com/en-us/library/6dwk3a1z.aspx
+endif
# this only exists on linux so either this is linux and it will be found, or
# it's not linux and wont
dep_m = cc.find_library('m', required : false)