summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Lecluse <philippe.lecluse@intel.com>2022-11-22 07:26:58 -0800
committerMarge Bot <emma+marge@anholt.net>2022-11-23 16:57:23 +0000
commita821dfbda5681c91c1fc80aebe269a63945a4543 (patch)
tree326e420ce3f853e26d0d3e872151001d1b04bea3 /meson.build
parentf2e535e4fed5bdc13e11a443316a4b77cd5eb81a (diff)
downloadmesa-a821dfbda5681c91c1fc80aebe269a63945a4543.tar.gz
intel: Add SUPPORT_INTEL_INTEGRATED_GPUS build argument
This is meant to remove any integrated GPU only code paths that can't be compiled in CPU architectures different than x86. Discrete GPUS don't have need_clflush set to true so it was just matter of remove some code blocks around need_clflush but was left a check in anv_physical_device_init_heaps() to fail physical device initialization if it ever became false. Signed-off-by: Philippe Lecluse <philippe.lecluse@intel.com> Signed-off-by: José Roberto de Souza <jose.souza@intel.com> Reviewed-by: Marcin Ślusarz <marcin.slusarz@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19812>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 90a92e5e517..da661006760 100644
--- a/meson.build
+++ b/meson.build
@@ -1572,6 +1572,11 @@ elif with_intel_vk or with_intel_hasvk
error('Intel "Anvil" Vulkan driver requires the dl_iterate_phdr function')
endif
+# only used in Iris and ANV
+if with_any_intel and ['x86', 'x86_64'].contains(host_machine.cpu_family())
+ pre_args += '-DSUPPORT_INTEL_INTEGRATED_GPUS'
+endif
+
# Determine whether or not the rt library is needed for time functions
if host_machine.system() == 'windows' or cc.has_function('clock_gettime')
dep_clock = null_dep