summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPavel Ondračka <pavel.ondracka@gmail.com>2023-01-04 17:27:14 +0100
committerMarge Bot <emma+marge@anholt.net>2023-02-24 06:04:32 +0000
commita06ab9849db7fdf8f5194412f0c5a15abd8ece9b (patch)
tree2d4d45159f943100af98b2e02bef8028171c52c9 /meson.build
parent865e9311a29c193f1b331646dbeeccce8c461365 (diff)
downloadmesa-a06ab9849db7fdf8f5194412f0c5a15abd8ece9b.tar.gz
r300: drop VDPAU support
There is no UVD and the mpeg2 shader-based decoding is broken and doesn't lead to CPU savings anyway. VDPAU output works, but there is no real benefit so just disable VDPAU altogether so we can clean the backend a bit and also open a way to potentially drop the mpeg2 deconding altogether from the fronted. Acked-by: Filip Gawin <filip@gawin.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20524>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index cab995ee13b..03fcc1a0381 100644
--- a/meson.build
+++ b/meson.build
@@ -526,7 +526,6 @@ endif
_vdpau_drivers = [
with_gallium_d3d12_video,
with_gallium_nouveau,
- with_gallium_r300,
with_gallium_r600,
with_gallium_radeonsi,
with_gallium_virgl,
@@ -535,7 +534,7 @@ _vdpau_drivers = [
vdpau = get_option('gallium-vdpau') \
.require(system_has_kms_drm, error_message : 'VDPAU state tracker can only be build on unix-like OSes.') \
.require(with_platform_x11, error_message : 'VDPAU state tracker requires X11 support.') \
- .require(_vdpau_drivers.contains(true), error_message : 'VDPAU state tracker requires at least one of the following gallium drivers: r300, r600, radeonsi, nouveau, d3d12 (with option gallium-d3d12-video, virgl).')
+ .require(_vdpau_drivers.contains(true), error_message : 'VDPAU state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau, d3d12 (with option gallium-d3d12-video, virgl).')
dep_vdpau = dependency('vdpau', version : '>= 1.1', required : vdpau)
if dep_vdpau.found()