summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJames Jones <jajones@nvidia.com>2021-04-22 23:18:49 -0700
committerMarge Bot <eric+marge@anholt.net>2021-07-06 16:57:59 +0000
commit7f615c66fbdd0a7aa7a513d011956dcc6c0ac2e6 (patch)
tree5ca1976bf0248590bde34da14b7afa241f683400 /meson.build
parentbc343154f816b637b200933e1c1a35db19f478ef (diff)
downloadmesa-7f615c66fbdd0a7aa7a513d011956dcc6c0ac2e6.tar.gz
meson: Add a GBM backends search path build option
This is the list of locations where GBM will look for alternate backend implementations based on the DRM driver name. It defaults to $libdir/gbm. On Android, this path is currently hard-coded to /vendor/lib[64]/gbm. Signed-off-by: James Jones <jajones@nvidia.com> Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/9902>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 303414c4c3e..2ef0b88e6d3 100644
--- a/meson.build
+++ b/meson.build
@@ -92,6 +92,11 @@ if dri_search_path == ''
dri_search_path = dri_drivers_path
endif
+gbm_backends_path = get_option('gbm-backends-path')
+if gbm_backends_path == ''
+ gbm_backends_path = join_paths(get_option('prefix'), get_option('libdir'), 'gbm')
+endif
+
with_gles1 = get_option('gles1')
if with_gles1 == 'true'
with_gles1 = 'enabled'
@@ -2162,7 +2167,6 @@ if with_egl
endif
lines += 'EGL drivers: ' + ' '.join(egl_drivers)
endif
-lines += 'GBM: ' + (with_gbm ? 'yes' : 'no')
if with_egl or with_any_vk
_platforms += 'surfaceless'
if with_gbm and not with_platform_android
@@ -2170,6 +2174,10 @@ if with_egl or with_any_vk
endif
lines += 'EGL/Vulkan/VL platforms: ' + ' '.join(_platforms)
endif
+lines += 'GBM: ' + (with_gbm ? 'yes' : 'no')
+if with_gbm
+ lines += 'GBM backends path: ' + gbm_backends_path
+endif
lines += ''
if with_any_vk