summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2022-11-06 00:12:53 +0800
committerMarge Bot <emma+marge@anholt.net>2022-11-09 13:30:24 +0000
commit4d058a7034c24594637de72563456ce7882b9bc8 (patch)
tree1858f222c6bcb93394e8376debc509a81cda414e /meson.build
parent560b3276960abd6955e72e85f44c110386274a06 (diff)
downloadmesa-4d058a7034c24594637de72563456ce7882b9bc8.tar.gz
meson: -DVK_ENABLE_BETA_EXTENSIONS at a single place
Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Eric Engestrom <eric@igalia.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19549>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index e384aa340b6..3e46cd50deb 100644
--- a/meson.build
+++ b/meson.build
@@ -321,6 +321,10 @@ else
endif
with_vulkan_beta = get_option('vulkan-beta')
+if host_machine.system() == 'darwin'
+ #macOS seems to need beta extensions to build for now:
+ with_vulkan_beta = true
+endif
if with_vulkan_beta
pre_args += '-DVK_ENABLE_BETA_EXTENSIONS'
endif
@@ -451,9 +455,6 @@ if host_machine.system() == 'darwin'
cpp_args += '-DVK_USE_PLATFORM_MACOS_MVK'
c_args += '-DVK_USE_PLATFORM_METAL_EXT'
cpp_args += '-DVK_USE_PLATFORM_METAL_EXT'
- #macOS seems to need beta extensions to build for now:
- c_args += '-DVK_ENABLE_BETA_EXTENSIONS'
- cpp_args += '-DVK_ENABLE_BETA_EXTENSIONS'
endif
_egl = get_option('egl')