summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMike Blumenkrantz <michael.blumenkrantz@gmail.com>2021-03-04 10:44:36 -0500
committerMarge Bot <emma+marge@anholt.net>2023-01-14 18:15:48 +0000
commit48a0478126ffd4e0bc1585e424cd90e8a0be36aa (patch)
treee8c1276d65897e9e1d9f9899c7886ea14e81f426 /meson.build
parent7e52bd7b18245bab3e722300c715e30932bb59ac (diff)
downloadmesa-48a0478126ffd4e0bc1585e424cd90e8a0be36aa.tar.gz
zink: add renderdoc handling
renderdoc won't work with zink in frontends that aren't dri, so ZINK_RENDERDOC should be used to specify start:end frames to ensure that the vulkan command stream is captured this is not a renderdoc issue: there are no frame boundaries in rusticl or gallium-nine, so there is no possible way that renderdoc could determine when/how to split frames Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20651>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index beb5c6f0c23..79baae7b45f 100644
--- a/meson.build
+++ b/meson.build
@@ -1438,7 +1438,8 @@ if not ['linux'].contains(host_machine.system())
endif
endif
-foreach h : ['xlocale.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'sys/shm.h', 'cet.h', 'pthread_np.h']
+foreach h : ['xlocale.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'sys/shm.h',
+ 'cet.h', 'pthread_np.h', 'renderdoc_app.h']
if cc.check_header(h)
pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
endif