summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2022-12-21 09:31:30 -0800
committerMarge Bot <emma+marge@anholt.net>2023-01-19 16:29:03 +0000
commit3c5e96914474fcb2b218cbefc43c213739252829 (patch)
treec748e2f840f55e2cfd8efafddb3471850235f86e /meson.build
parent92235e0c48f6d23f51c63a847f987eb23b885f5a (diff)
downloadmesa-3c5e96914474fcb2b218cbefc43c213739252829.tar.gz
meson: replace uses of ExternalProgram.path with .full_path
The former is deprecated Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Acked-by: Alyssa Rosenzweig <alyssa.rosenzweig@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20409>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 911cc066c03..6bece9b6a53 100644
--- a/meson.build
+++ b/meson.build
@@ -2326,12 +2326,12 @@ if host_machine.system() == 'windows'
prog_dumpbin = find_program('dumpbin', required : false)
with_symbols_check = prog_dumpbin.found() and with_tests
if with_symbols_check
- symbols_check_args = ['--dumpbin', prog_dumpbin.path()]
+ symbols_check_args = ['--dumpbin', prog_dumpbin.full_path()]
endif
else
prog_nm = find_program('nm')
with_symbols_check = with_tests
- symbols_check_args = ['--nm', prog_nm.path()]
+ symbols_check_args = ['--nm', prog_nm.full_path()]
endif
# This quirk needs to be applied to sources with functions defined in assembly