summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuis Felipe Strano Moraes <luis.strano@gmail.com>2022-10-26 15:08:22 -0700
committerMarge Bot <emma+marge@anholt.net>2022-11-01 06:30:47 +0000
commit2842c04bf50ea2d7bf6a45c898558277f3f8c69f (patch)
tree0c87bd49b812ee35aa48cea23b8b4f7068fd4f3a /meson.build
parentfda7d17e81e91d75e6bd10b633d4c767d13fc6c0 (diff)
downloadmesa-2842c04bf50ea2d7bf6a45c898558277f3f8c69f.tar.gz
meson: simplified meson for enabling ray-tracing on Intel
Removed warning about deprecated usage that was not necessary. Also added information on whether support is enabled or not to the summary so it is easier to check when building. Reviewed-by: Jordan Justen <jordan.l.justen@intel.com> Reviewed-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19332>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 7f86a0ec985..6289f11afd0 100644
--- a/meson.build
+++ b/meson.build
@@ -286,11 +286,6 @@ with_imagination_srv = get_option('imagination-srv')
with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
with_any_vk = _vulkan_drivers.length() != 0
-_vulkan_rt_drivers = get_option('vulkan-rt-drivers')
-if _vulkan_rt_drivers.contains('intel')
- error('Use -Dintel-clc=enabled to enable Intel Vulkan Ray Tracing')
-endif
-
with_any_broadcom = with_gallium_vc4 or with_gallium_v3d or with_broadcom_vk
with_any_intel = with_intel_vk or with_intel_hasvk or with_gallium_iris or with_gallium_crocus or with_intel_tools
@@ -306,7 +301,7 @@ endif
with_microsoft_clc = get_option('microsoft-clc').enabled()
with_intel_clc = get_option('intel-clc').enabled()
-with_intel_vk_rt = with_intel_clc
+with_intel_vk_rt = with_intel_vk and with_intel_clc
with_clc = with_microsoft_clc or with_intel_clc
with_libclc = with_clc
with_spirv_to_dxil = get_option('spirv-to-dxil')
@@ -2358,6 +2353,7 @@ if with_any_vk
if with_any_vulkan_layers
lines += 'Vulkan layers: ' + ' '.join(get_option('vulkan-layers'))
endif
+ lines += 'Vulkan Intel Ray Tracing: ' + (with_intel_vk_rt ? 'yes' : 'no')
else
lines += 'Vulkan drivers: no'
endif