summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2022-03-22 17:44:02 +0000
committerDaniel P. Berrangé <berrange@redhat.com>2022-04-21 15:00:29 +0000
commitd4dfac2a4328eb56b10c14195fdd4dc8faadbec4 (patch)
tree0e44813f27a763ec75193c1b23e7b2a91ce89f52 /setup.py
parent4e5d903fc343501ac9a2be5584925f0d64d1e6dd (diff)
downloadlibvirt-python-d4dfac2a4328eb56b10c14195fdd4dc8faadbec4.tar.gz
sanitytest: stop passing python module path into sanity test
We want to move over to make sanitytest.py operate like a more normal test script, which means making it self contained. The setup.py already sets the PYTHONPATH thanks to changes introduced in: commit eaded7bdadf3ccdc4b208ec0ed65a1b23b8b5f69 Author: Daniel P. Berrange <berrange@redhat.com> Date: Tue Mar 18 11:11:48 2014 +0000 Add support for running unit tests with nose so passing the python module path into sanitytest.py is redundant. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 729481e..a6a53bb 100755
--- a/setup.py
+++ b/setup.py
@@ -310,7 +310,7 @@ class my_test(Command):
os.environ["PYTHONPATH"] = self.build_platlib
if "LIBVIRT_API_COVERAGE" in os.environ:
- self.spawn([sys.executable, "sanitytest.py", self.build_platlib])
+ self.spawn([sys.executable, "sanitytest.py"])
pytest = self.find_pytest_path()
subprocess.check_call([pytest])