summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2022-03-22 17:44:02 +0000
committerDaniel P. Berrangé <berrange@redhat.com>2022-04-21 15:00:29 +0000
commit4e5d903fc343501ac9a2be5584925f0d64d1e6dd (patch)
tree88a6d22bc3ec6abd56d630f1cfe9ab0a99b83a17 /setup.py
parentb0e9f12f2fe1f44250a322fda1a68f91c4f003a5 (diff)
downloadlibvirt-python-4e5d903fc343501ac9a2be5584925f0d64d1e6dd.tar.gz
sanitytest: stop passing API XML path into sanity test
We want to move over to make sanitytest.py operate like a more normal test script, which means making it self contained. The test already knows how to find the libvirt API XML path using pkg-config and if an override location is required, this can be done by pointing $PKG_CONFIG_PATH to a suitable place. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index f48c5ab..729481e 100755
--- a/setup.py
+++ b/setup.py
@@ -304,15 +304,13 @@ class my_test(Command):
Run test suite
"""
- apis = get_api_xml_files()
-
if "PYTHONPATH" in os.environ:
os.environ["PYTHONPATH"] = self.build_platlib + ":" + os.environ["PYTHONPATH"]
else:
os.environ["PYTHONPATH"] = self.build_platlib
if "LIBVIRT_API_COVERAGE" in os.environ:
- self.spawn([sys.executable, "sanitytest.py", self.build_platlib, apis[0]])
+ self.spawn([sys.executable, "sanitytest.py", self.build_platlib])
pytest = self.find_pytest_path()
subprocess.check_call([pytest])