summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2022-03-24 12:05:41 +0000
committerDaniel P. Berrangé <berrange@redhat.com>2022-04-21 12:34:06 +0100
commita965c91c6fa1275613edbbef75c0422574eb9ff2 (patch)
tree40a80583128d8d157c15033f1f3881a3dda0e432 /setup.py
parent6ea035b0e370e3606eacc2cd2caa609bb1d16fdd (diff)
downloadlibvirt-python-a965c91c6fa1275613edbbef75c0422574eb9ff2.tar.gz
setup: stop inheriting from 'clean' command
The default 'clean' command impl deletes only intermediate files from the 'build' directory. We've overridden it to delete everything. There is no benefit in inheriting from the default impl, given our subclass will delete everything. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 669c590..8ba6669 100755
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,6 @@
from distutils.core import setup, Extension, Command
from distutils.command.build import build
-from distutils.command.clean import clean
from distutils.command.sdist import sdist
from distutils.dir_util import remove_tree
from distutils.util import get_platform
@@ -300,10 +299,8 @@ class my_test(Command):
self.spawn([sys.executable, pytest])
-class my_clean(clean):
+class my_clean(Command):
def run(self):
- clean.run(self)
-
if os.path.exists("build"):
remove_tree("build")