summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2022-03-24 12:04:14 +0000
committerDaniel P. Berrangé <berrange@redhat.com>2022-04-21 12:34:06 +0100
commit6ea035b0e370e3606eacc2cd2caa609bb1d16fdd (patch)
tree527ef913b3ddc413c96bd754ba8a21ade5b730a1 /setup.py
parentf8c9ec5387d0afdd920b53581ebb1107a20a2fc2 (diff)
downloadlibvirt-python-6ea035b0e370e3606eacc2cd2caa609bb1d16fdd.tar.gz
setup: drop the 'rpm' command
This duplicates funtionality already provided by the 'bdist_rpm' command. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 0 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 3191f95..669c590 100755
--- a/setup.py
+++ b/setup.py
@@ -233,26 +233,6 @@ class my_sdist(sdist):
else:
sdist.run(self)
-class my_rpm(Command):
- user_options = []
-
- description = "Build src and noarch rpms."
-
- def initialize_options(self):
- pass
-
- def finalize_options(self):
- pass
-
- def run(self):
- """
- Run sdist, then 'rpmbuild' the tar.gz
- """
-
- self.run_command('sdist')
- self.spawn(["/usr/bin/rpmbuild", "-ta", "--clean",
- "dist/libvirt-python-%s.tar.gz" % self.distribution.get_version()])
-
class my_test(Command):
user_options = [
('build-base=', 'b',
@@ -355,7 +335,6 @@ of recent versions of Linux (and other OSes).''',
'build': my_build,
'clean': my_clean,
'sdist': my_sdist,
- 'rpm': my_rpm,
'test': my_test
},
classifiers = [