summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJán Tomko <jtomko@redhat.com>2021-04-06 20:07:25 +0200
committerJán Tomko <jtomko@redhat.com>2021-04-07 17:09:54 +0200
commita376a2abb023f4e53e5d9d353c725913c8711c6e (patch)
tree045a117f5a2f981c0922ea0117b2d8a04ddd615b /setup.py
parent98b9db087fe03b42bb58225a072b214d969ba443 (diff)
downloadlibvirt-python-a376a2abb023f4e53e5d9d353c725913c8711c6e.tar.gz
setup: use pytest instead of nose to run the test suite
The software we use for running tests - nose - has been deprecated in favor of nose2. We don't use anything nose-specific, just unittest.TestCase, which pytest can handle just fine. Switch to using pytest, which we already use for libvirt-dbus. Signed-off-by: Ján Tomko <jtomko@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 8 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 3474ca3..af81968 100755
--- a/setup.py
+++ b/setup.py
@@ -286,13 +286,13 @@ class my_test(Command):
self.build_platlib = os.path.join(self.build_base,
'lib' + plat_specifier)
- def find_nosetests_path(self):
+ def find_pytest_path(self):
binaries = [
- "nosetests-%d.%d" % (sys.version_info[0],
+ "pytest-%d.%d" % (sys.version_info[0],
sys.version_info[1]),
- "nosetests-%d" % (sys.version_info[0]),
- "nosetests%d" % (sys.version_info[0]),
- "nosetests",
+ "pytest-%d" % (sys.version_info[0]),
+ "pytest%d" % (sys.version_info[0]),
+ "pytest",
]
for binary in binaries:
@@ -300,7 +300,7 @@ class my_test(Command):
if path is not None:
return path
- raise Exception("Cannot find any nosetests binary")
+ raise Exception("Cannot find any pytest binary")
def run(self):
"""
@@ -314,8 +314,8 @@ class my_test(Command):
else:
os.environ["PYTHONPATH"] = self.build_platlib
self.spawn([sys.executable, "sanitytest.py", self.build_platlib, apis[0]])
- nose = self.find_nosetests_path()
- self.spawn([sys.executable, nose])
+ pytest = self.find_pytest_path()
+ self.spawn([sys.executable, pytest])
class my_clean(clean):