summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJán Tomko <jtomko@redhat.com>2021-04-06 19:49:32 +0200
committerJán Tomko <jtomko@redhat.com>2021-04-07 16:25:45 +0200
commit98b9db087fe03b42bb58225a072b214d969ba443 (patch)
tree8e3ba71b37474ba48660d588716f1259c93513ab /setup.py
parentce6d4369ba1c9c3c756b3f3cd438be8df397464e (diff)
downloadlibvirt-python-98b9db087fe03b42bb58225a072b214d969ba443.tar.gz
setup: drop have_libvirtaio
This function says we have libvirtaio on Python >= 3.3, however we already mandate Python >= 3.5 at the start of the file. Signed-off-by: Ján Tomko <jtomko@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 2 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 08c139e..3474ca3 100755
--- a/setup.py
+++ b/setup.py
@@ -55,12 +55,6 @@ def have_libvirt_lxc():
except DistutilsExecError:
return False
-def have_libvirtaio():
- # This depends on asyncio, which in turn depends on "yield from" syntax.
- # The asyncio module itself is in standard library since 3.4, but there is
- # an out-of-tree version compatible with 3.3.
- return sys.version_info >= (3, 3)
-
def get_pkgconfig_data(args, mod, required=True):
"""Run pkg-config to and return content associated with it"""
f = os.popen("%s %s %s" % (get_pkgcfg(), " ".join(args), mod))
@@ -135,8 +129,7 @@ def get_module_lists():
c_modules.append(modulelxc)
py_modules.append("libvirt_lxc")
- if have_libvirtaio():
- py_modules.append("libvirtaio")
+ py_modules.append("libvirtaio")
return c_modules, py_modules
@@ -155,8 +148,7 @@ class my_build(build):
self.spawn([sys.executable, "generator.py", "libvirt-qemu", apis[1]])
if have_libvirt_lxc():
self.spawn([sys.executable, "generator.py", "libvirt-lxc", apis[2]])
- if have_libvirtaio():
- shutil.copy('libvirtaio.py', 'build')
+ shutil.copy('libvirtaio.py', 'build')
build.run(self)