summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2022-03-23 11:16:00 +0000
committerDaniel P. Berrangé <berrange@redhat.com>2022-04-21 12:34:06 +0100
commitb0e9f12f2fe1f44250a322fda1a68f91c4f003a5 (patch)
treefc07f7534dd13beb5e9a883a2f6381bf25fa02ae /setup.py
parente00e8c39c272b8675ea353e1cfd1d5393922e096 (diff)
downloadlibvirt-python-b0e9f12f2fe1f44250a322fda1a68f91c4f003a5.tar.gz
setup: switch from distutils to setuptools
The distutils package is deprecated and targetted for deletion in Python 3.12, so we need to switch to setuptools. Thanks to all the preceeding changes this is no more difficult than changing the import statements. Closes https://gitlab.com/libvirt/libvirt-python/-/issues/1 Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index bfbe037..f48c5ab 100755
--- a/setup.py
+++ b/setup.py
@@ -1,9 +1,9 @@
#!/usr/bin/env python3
-from distutils.core import setup, Extension, Command
-from distutils.command.build_ext import build_ext
-from distutils.command.build_py import build_py
-from distutils.command.sdist import sdist
+from setuptools import setup, Extension, Command
+from setuptools.command.build_ext import build_ext
+from setuptools.command.build_py import build_py
+from setuptools.command.sdist import sdist
import glob
import sys