summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2018-01-22 15:04:08 +0100
committerXiang, Haihao <haihao.xiang@intel.com>2018-02-11 19:35:46 +0800
commitcfe15845781e769db24124c101382e6790a9476c (patch)
treed1e1059605766e01322cde0377345b6d5d4041ab /configure.ac
parent1e066eac4dc3dd479caf9970b7761ef6809f4a31 (diff)
downloadlibva-intel-driver-cfe15845781e769db24124c101382e6790a9476c.tar.gz
build: autotools: don't check for EGL
libEGL is loaded in run-time using dlopen, thus there is no need to check for it at comiplation time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index c7ee49fb..69fe83b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,25 +156,6 @@ fi
AC_MSG_RESULT([$LIBVA_DRIVERS_PATH])
AC_SUBST(LIBVA_DRIVERS_PATH)
-# Check for EGL
-if test "$enable_wayland" = "yes"; then
- enable_egl="yes"
-fi
-
-USE_EGL="no"
-if test "$enable_egl" = "yes"; then
- PKG_CHECK_MODULES([EGL], [egl], [USE_EGL="yes"], [USE_EGL="no"])
- saved_CPPFLAGS="$CPPFLAGS"
- saved_LIBS="$LIBS"
- CPPFLAGS="$CPPFLAGS $EGL_CFLAGS"
- LIBS="$LIBS $EGL_LIBS"
- AC_CHECK_HEADERS([EGL/egl.h], [:], [USE_EGL="no"])
- AC_CHECK_LIB([EGL], [eglGetDisplay], [:], [USE_EGL="no"])
- CPPFLAGS="$saved_CPPFLAGS"
- LIBS="$saved_LIBS"
-fi
-AM_CONDITIONAL(USE_EGL, test "$USE_EGL" = "yes")
-
# Check for Wayland
USE_WAYLAND="no"
if test "$enable_wayland" = "yes"; then