summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2018-01-22 15:14:24 +0100
committerXiang, Haihao <haihao.xiang@intel.com>2018-02-11 19:35:46 +0800
commit1e066eac4dc3dd479caf9970b7761ef6809f4a31 (patch)
treee23a696485c6302cd99f3564a57603559e7685af /configure.ac
parent3497cb12e493059b418341d84332ba29183e42a6 (diff)
downloadlibva-intel-driver-1e066eac4dc3dd479caf9970b7761ef6809f4a31.tar.gz
build: autotools: check for dlopen library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 583ae5a9..c7ee49fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,10 @@ AC_CHECK_PROGS([PYTHON2], [python2 python])
LIBVA_PACKAGE_VERSION=libva_package_version
AC_SUBST(LIBVA_PACKAGE_VERSION)
+AC_SEARCH_LIBS([dlopen], [dl], [], [
+ AC_MSG_ERROR([unable to find the dlopen() function])
+])
+
dnl Check for recent enough DRM
LIBDRM_VERSION=libdrm_version
PKG_CHECK_MODULES([DRM], [libdrm >= $LIBDRM_VERSION libdrm_intel])