summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 14 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 19afd97de..e3b1aa48b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,18 +233,20 @@ GP_VA_COPY
dnl check for/set up libtool and libltdl
-dnl AC_DISABLE_STATIC
-dnl AC_DISABLE_SHARED
-dnl AC_LIBLTDL_CONVENIENCE([libltdl])
-dnl AC_WITH_LTDL
-dnl AC_LIB_LTDL
-AC_DISABLE_STATIC
-AC_LIBTOOL_WIN32_DLL
-AC_LIBTOOL_DLOPEN
-AC_PROG_LIBTOOL
-
-dnl We are using our own libltdl checks instead of AC_WITH_LTDL
-dnl because we do not want to ship our own copy of libltdl.
+LT_PREREQ([2.4.2])
+dnl Disable building static library, as no one uses it anyway.
+LT_INIT([
+ disable-static
+ dlopen
+ win32-dll
+])
+dnl
+dnl LTDL_INIT([external])
+dnl
+dnl We are using our own libltdl checks instead of LTDL_INIT because
+dnl we do not want to ship our own two copies of libltdl (one for
+dnl libgphoto2 and one for libgphoto2_port), and LTDL_INIT insists on
+dnl that.
GP_LIBLTDL