summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-10-25 20:07:09 +0200
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-01 18:42:04 +0100
commit173a9fa5d6070a0bdf1fb54977b9ab6b9ce0134f (patch)
treed8ba630a7d726d3a852a49b5f070ec922d5c9936 /configure.ac
parent9270f0d69ec7096286c592a5543fecdf7bfbef11 (diff)
downloadlibgphoto2-173a9fa5d6070a0bdf1fb54977b9ab6b9ce0134f.tar.gz
Require at least libtool 2.4.2, use LT_INIT
This gives us a few more features and fixes to rely on which are present in libtool 2.4.2 (released 2011-10-18), which is older than our autoconf, automake, and gettext requirements and should therefore not exclude anyone from building libgphoto2. Update the libtool initialization to use the more modern (modern in the sense of libtool 1.9b from 2004-08-29) LT_INIT macro. We still do not use LTDL_INIT() as that (like AC_WITH_LTDL used to) insists on us shipping libltdl sources in our release tarballs, and we do not like shipping third party sources.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 14 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 19afd97de..e3b1aa48b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,18 +233,20 @@ GP_VA_COPY
dnl check for/set up libtool and libltdl
-dnl AC_DISABLE_STATIC
-dnl AC_DISABLE_SHARED
-dnl AC_LIBLTDL_CONVENIENCE([libltdl])
-dnl AC_WITH_LTDL
-dnl AC_LIB_LTDL
-AC_DISABLE_STATIC
-AC_LIBTOOL_WIN32_DLL
-AC_LIBTOOL_DLOPEN
-AC_PROG_LIBTOOL
-
-dnl We are using our own libltdl checks instead of AC_WITH_LTDL
-dnl because we do not want to ship our own copy of libltdl.
+LT_PREREQ([2.4.2])
+dnl Disable building static library, as no one uses it anyway.
+LT_INIT([
+ disable-static
+ dlopen
+ win32-dll
+])
+dnl
+dnl LTDL_INIT([external])
+dnl
+dnl We are using our own libltdl checks instead of LTDL_INIT because
+dnl we do not want to ship our own two copies of libltdl (one for
+dnl libgphoto2 and one for libgphoto2_port), and LTDL_INIT insists on
+dnl that.
GP_LIBLTDL