summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-09 11:53:04 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-12 16:35:47 +0100
commit397ae74674698122b4696ac897e70de439a2d0c9 (patch)
treeca9f94e23cc1d2970c6aeb4990d1fa99610f8c03 /configure.ac
parentd18b440a72407fc371ec17a2a983976b813e5d97 (diff)
downloadlibgphoto2-397ae74674698122b4696ac897e70de439a2d0c9.tar.gz
Add pull-translations target
Add pull-translations target to make it easier to pull translations from the Translation Project: make pull-translations
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3a613c892..974a2938a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,6 +122,12 @@ dnl compile when included into C++ source files.
AM_CONDITIONAL([HAVE_CXX], [test "x$CXX" != "x" && test "x$CXX" != "xno"])
+dnl Not strictly necessary, but helps pulling translations.
+AC_ARG_VAR([RSYNC], [rsync file copying command])
+AC_PATH_PROG([RSYNC], [rsync], [no])
+AM_CONDITIONAL([HAVE_RSYNC], [test "x$RSYNC" != xno])
+
+
dnl --------------------------------------------------------------------
dnl Determine the most pedantic compiler flags we can find for both
dnl C and C++, so that we can test that the libgphoto2 headers compile