summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-10-31 09:02:20 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-10 21:47:34 +0100
commitd18b440a72407fc371ec17a2a983976b813e5d97 (patch)
treeefe579a1ef9b0b856da3a7bd27de7a5cd03fb7c5 /configure.ac
parentb2d8e106ae31b59e0ec9ecf9534376f97b9dbe1c (diff)
downloadlibgphoto2-d18b440a72407fc371ec17a2a983976b813e5d97.tar.gz
Require gettext >= 0.18.3; remove GP_GETTEXT_HACK
This requires gettext version 0.18.3 or later, and it removes the GP_GETTEXT_HACK which used to generate a po/Makevars file from the po/Makevers.template. gettext 0.18.3 is the same gettext version requirement as libexif uses. gettext 0.18.3 has been released 2013-07-07, which is a similar timeframe of the autoconf, automake and libtool releases we require. If you ever need to build a post 2021 libgphoto2 from git on a system with pre 0.18.3 gettext, you can can always prepare a tarball using "make dist" on a system with gettext 0.18.3 or later, and build that tarball on the older machine. Not generating the po/Makevars file any more means that we need additional consistency checks for the parts of po/Makevars which cannot be derived from the Autoconf standard set of AC_SUBST()ed Makefile.in variables.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e3b1aa48b..3a613c892 100644
--- a/configure.ac
+++ b/configure.ac
@@ -273,17 +273,16 @@ dnl ---------------------------------------------------------------------------
dnl i18n support (including some hacks)
dnl ---------------------------------------------------------------------------
-GP_GETTEXT_HACK([GETTEXT_PACKAGE_LIBGPHOTO2],
- [${PACKAGE}-${LIBGPHOTO2_CURRENT_MIN}],
- [The gPhoto Team],
- [${MAIL_GPHOTO_TRANSLATION}])
+GP_GETTEXT_SETUP([GETTEXT_PACKAGE_LIBGPHOTO2],
+ [${PACKAGE}-${LIBGPHOTO2_CURRENT_MIN}],
+ [po])
AM_PO_SUBDIRS()
-AM_GNU_GETTEXT_VERSION([0.14.1])
+AM_GNU_GETTEXT_VERSION([0.18.3])
AM_GNU_GETTEXT([external])
AM_ICONV()
-GP_GETTEXT_FLAGS()
-AM_CPPFLAGS="$AM_CPPFLAGS -DLOCALEDIR=\\\"${localedir}\\\""
+GP_CONFIG_MSG([Use translations],
+ [${USE_NLS}])
dnl FIXME: We have to make sure this works first
dnl AC_CHECK_FUNC(gettext, gettext_without_libintl=true)