summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-09-26 22:02:04 -0400
committerEdward Thomson <ethomson@edwardthomson.com>2021-10-18 08:30:14 -0400
commite1be28c7cc6a352078ef8ce9ce8234a5f9a0a27a (patch)
tree7e386f7c0f5018163c006bd9daf8e681875c74fd /CMakeLists.txt
parent8507bf81ea5cf11a99566f449e6b3af68bd02430 (diff)
downloadlibgit2-e1be28c7cc6a352078ef8ce9ce8234a5f9a0a27a.tar.gz
cmake: remove unused STDCALL option
The `STDCALL` option was removed; remove the (unreachable) error message.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cab0cb268..fa2264524 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,10 +97,6 @@ ENDIF()
# Platform specific compilation flags
IF (MSVC)
- IF (STDCALL)
- MESSAGE(FATAL_ERROR "The STDCALL option is no longer supported; libgit2 is now always built as a cdecl library. If you're using PInvoke, please add the CallingConventions.Cdecl attribute for support.")
- ENDIF()
-
ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS)
ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
ADD_DEFINITIONS(-D_CRT_NONSTDC_NO_DEPRECATE)