summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2016-02-20 06:50:29 -0500
committerAnthony Green <green@moxielogic.com>2016-02-20 06:50:29 -0500
commitf2f234aef203a5e836b83cb772f9473f7ea0d5ce (patch)
tree74ebd49a5e2b276d3c1bed609343f252986eeed7 /configure.ac
parent49b95edafd712ce27e08b1bb4be2987f14c54ca3 (diff)
parentfa7a257113e2cfc963a0be9dca5d7b4c73999dcc (diff)
downloadlibffi-f2f234aef203a5e836b83cb772f9473f7ea0d5ce.tar.gz
Merge pull request #190 from havardgraff/master
Add configure-option to disable building docs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74658c3..f177495 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,6 +282,13 @@ if test "x$GCC" = "xyes"; then
fi
fi
+AC_ARG_ENABLE(docs,
+ AC_HELP_STRING([--disable-docs],
+ [Disable building of docs (default: no)]),
+ [enable_docs=no],
+ [enable_docs=yes])
+AM_CONDITIONAL(BUILD_DOCS, [test x$enable_docs = xyes])
+
AH_BOTTOM([
#ifdef HAVE_HIDDEN_VISIBILITY_ATTRIBUTE
#ifdef LIBFFI_ASM