summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHavard Graff <havard.graff@gmail.com>2015-05-12 10:45:13 +0200
committerHavard Graff <havard.graff@gmail.com>2015-05-12 10:45:13 +0200
commitfa7a257113e2cfc963a0be9dca5d7b4c73999dcc (patch)
tree8c4b5a781fcfc440e4805be609b7bd60d98c6874 /configure.ac
parent17ffc3655a531c116e9eb9cc933e50bb1e5c47f8 (diff)
downloadlibffi-fa7a257113e2cfc963a0be9dca5d7b4c73999dcc.tar.gz
Add configure-option to disable building docs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 445c589..669c9f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,6 +282,13 @@ if test "x$GCC" = "xyes"; then
fi
fi
+AC_ARG_ENABLE(docs,
+ AC_HELP_STRING([--disable-docs],
+ [Disable building of docs (default: no)]),
+ [enable_docs=no],
+ [enable_docs=yes])
+AM_CONDITIONAL(BUILD_DOCS, [test x$enable_docs = xyes])
+
AH_BOTTOM([
#ifdef HAVE_HIDDEN_VISIBILITY_ATTRIBUTE
#ifdef LIBFFI_ASM