summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2668288..8ffdd29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,9 +173,18 @@ then
);
fi
-
AM_CONDITIONAL(IBUS_BUILD_LUA_EXTENSION, [test x"$enable_lua_extension" = x"yes"])
+# --disable-english-input-mode
+AC_ARG_ENABLE(english-input-mode,
+ AS_HELP_STRING([--disable-english-input-mode],
+ [do not build english input mode]),
+ [enable_english_input_mode=$enableval],
+ [enable_english_input_mode=yes]
+)
+
+AM_CONDITIONAL(IBUS_BUILD_ENGLISH_INPUT_MODE, [test x"$enable_english_input_mode" = x"yes"])
+
# OUTPUT files
AC_CONFIG_FILES([ po/Makefile.in
Makefile
@@ -205,5 +214,6 @@ Build options:
Build database android $enable_db_android
Build database open-phrase $enable_db_open_phrase
Build lua extension $enable_lua_extension
+ Build english input mode $enable_english_input_mode
])