summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2011-04-22 07:31:53 -0400
committerPeng Huang <shawn.p.huang@gmail.com>2011-04-22 07:31:53 -0400
commita16d70e01a441193c6bb8a38d7cf093a7ebed19c (patch)
treee198cdd089b593a735046520494154aa064b264a /configure.ac
parentd85a24507314194f1597c4c5d6c460408fcd3a9e (diff)
downloadibus-pinyin-a16d70e01a441193c6bb8a38d7cf093a7ebed19c.tar.gz
add English Editor
to speed up English input BUG=none TEST=build fine Review URL: http://codereview.appspot.com/4200041 Patch from Peng Wu <alexepico@gmail.com>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2668288..8ffdd29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,9 +173,18 @@ then
);
fi
-
AM_CONDITIONAL(IBUS_BUILD_LUA_EXTENSION, [test x"$enable_lua_extension" = x"yes"])
+# --disable-english-input-mode
+AC_ARG_ENABLE(english-input-mode,
+ AS_HELP_STRING([--disable-english-input-mode],
+ [do not build english input mode]),
+ [enable_english_input_mode=$enableval],
+ [enable_english_input_mode=yes]
+)
+
+AM_CONDITIONAL(IBUS_BUILD_ENGLISH_INPUT_MODE, [test x"$enable_english_input_mode" = x"yes"])
+
# OUTPUT files
AC_CONFIG_FILES([ po/Makefile.in
Makefile
@@ -205,5 +214,6 @@ Build options:
Build database android $enable_db_android
Build database open-phrase $enable_db_open_phrase
Build lua extension $enable_lua_extension
+ Build english input mode $enable_english_input_mode
])