summaryrefslogtreecommitdiff
path: root/examples/application10/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/application10/Makefile.am')
-rw-r--r--examples/application10/Makefile.am48
1 files changed, 0 insertions, 48 deletions
diff --git a/examples/application10/Makefile.am b/examples/application10/Makefile.am
deleted file mode 100644
index 47b7a11edf..0000000000
--- a/examples/application10/Makefile.am
+++ /dev/null
@@ -1,48 +0,0 @@
-GTK_CFLAGS = \
- -I$(top_srcdir) \
- $(GTK_DEP_CFLAGS)
-
-GTK_LIBS = \
- $(top_builddir)/gtk/libgtk-4.la \
- $(GTK_DEP_LIBS)
-
-
-noinst_PROGRAMS = exampleapp
-
-exampleapp_CFLAGS = $(GTK_CFLAGS)
-exampleapp_LDADD = $(GTK_LIBS)
-exampleapp_SOURCES = \
- main.c \
- exampleapp.c exampleapp.h \
- exampleappwin.c exampleappwin.h \
- exampleappprefs.c exampleappprefs.h \
- resources.c
-
-BUILT_SOURCES = \
- resources.c \
- gschemas.compiled
-
-resources.c: exampleapp.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/exampleapp.gresource.xml)
- $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $(srcdir)/exampleapp.gresource.xml \
- --target=$@ --sourcedir=$(srcdir) --generate-source
-
-gsettings_SCHEMAS = \
- org.gtk.exampleapp.gschema.xml
-
-@GSETTINGS_RULES@
-
-gschemas.compiled: org.gtk.exampleapp.gschema.xml
- $(GLIB_COMPILE_SCHEMAS) .
-
-EXTRA_DIST = \
- window.ui \
- app-menu.ui \
- prefs.ui \
- gears-menu.ui \
- exampleapp.gresource.xml \
- org.gtk.exampleapp.gschema.xml
-
-CLEANFILES = \
- gschemas.compiled
-
--include $(top_srcdir)/git.mk