summaryrefslogtreecommitdiff
path: root/examples/application10/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-08-13 12:57:45 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-08-14 22:23:09 +0100
commit391d1a04ec0c55e55653f553dc6a24f4077af52d (patch)
tree859c6f12c08a611c7a18c0604f5cded195fa79e4 /examples/application10/Makefile.am
parent562e278bf8f89be939320db05e06339f6a27d41d (diff)
downloadgtk+-391d1a04ec0c55e55653f553dc6a24f4077af52d.tar.gz
Drop Autotools build
We are officially switching to Meson as the default build system for GTK+.
Diffstat (limited to 'examples/application10/Makefile.am')
-rw-r--r--examples/application10/Makefile.am48
1 files changed, 0 insertions, 48 deletions
diff --git a/examples/application10/Makefile.am b/examples/application10/Makefile.am
deleted file mode 100644
index 47b7a11edf..0000000000
--- a/examples/application10/Makefile.am
+++ /dev/null
@@ -1,48 +0,0 @@
-GTK_CFLAGS = \
- -I$(top_srcdir) \
- $(GTK_DEP_CFLAGS)
-
-GTK_LIBS = \
- $(top_builddir)/gtk/libgtk-4.la \
- $(GTK_DEP_LIBS)
-
-
-noinst_PROGRAMS = exampleapp
-
-exampleapp_CFLAGS = $(GTK_CFLAGS)
-exampleapp_LDADD = $(GTK_LIBS)
-exampleapp_SOURCES = \
- main.c \
- exampleapp.c exampleapp.h \
- exampleappwin.c exampleappwin.h \
- exampleappprefs.c exampleappprefs.h \
- resources.c
-
-BUILT_SOURCES = \
- resources.c \
- gschemas.compiled
-
-resources.c: exampleapp.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/exampleapp.gresource.xml)
- $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $(srcdir)/exampleapp.gresource.xml \
- --target=$@ --sourcedir=$(srcdir) --generate-source
-
-gsettings_SCHEMAS = \
- org.gtk.exampleapp.gschema.xml
-
-@GSETTINGS_RULES@
-
-gschemas.compiled: org.gtk.exampleapp.gschema.xml
- $(GLIB_COMPILE_SCHEMAS) .
-
-EXTRA_DIST = \
- window.ui \
- app-menu.ui \
- prefs.ui \
- gears-menu.ui \
- exampleapp.gresource.xml \
- org.gtk.exampleapp.gschema.xml
-
-CLEANFILES = \
- gschemas.compiled
-
--include $(top_srcdir)/git.mk