summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index e5cf0e0c3b..525c7cf6d9 100644
--- a/meson.build
+++ b/meson.build
@@ -16,17 +16,17 @@ fs = import('fs')
gnome = import('gnome')
pkgconfig = import('pkgconfig')
python3 = import('python').find_installation()
-# Ensure that we're not being run from inside the gst-uninstalled env
+# Ensure that we're not being run from inside the development environment
# because that will confuse meson, and it might find the already-built
# gstreamer. It's fine if people run `ninja` as long as it doesn't run
# reconfigure because ninja doesn't care about the env.
-ensure_not_uninstalled = '''
+ensure_not_devenv = '''
import os
assert('GST_ENV' not in os.environ)
'''
-cmdres = run_command(python3, '-c', ensure_not_uninstalled, check: false)
+cmdres = run_command(python3, '-c', ensure_not_devenv, check: false)
if cmdres.returncode() != 0
- error('Do not run `ninja` or `meson` for gst-build inside the uninstalled environment, you will run into problems')
+ error('Do not run `ninja` or `meson` for gst-build inside the development environment, you will run into problems')
endif
# Install gst-indent pre-commit hook
@@ -395,7 +395,6 @@ if meson.can_run_host_binaries() and build_machine.system() == 'linux' and host_
endif
endif
-run_target('uninstalled', command : devenv_cmd)
run_target('devenv', command : devenv_cmd)
if orc_subproject.found() and orc_update_targets.length() > 0