summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSebastian Fricke <sebastian.fricke@collabora.com>2022-02-21 10:49:15 +0100
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-03-01 11:33:10 +0000
commit0b6bbce0122b45bcac9b17ac904035c8c1354e3c (patch)
treead2ae6c930338b6e13c5cd147f2ec401f4dffd92 /meson.build
parent57158f419491a98585054d9554d8a6c702684bc7 (diff)
downloadgstreamer-0b6bbce0122b45bcac9b17ac904035c8c1354e3c.tar.gz
Remove the uninstalled term
Remove the symbolic link `gst-uninstalled` which points to `gst-env`. The `uninstalled` is the old name and the project should stick to a single name for the procedure. Remove the term from all the files, exceptions are variables from dependencies like `uninstalled_variables` from pkgconfig and `meson-uninstalled`. Adjust mentions of the script in the documentation and README. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1743>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index e5cf0e0c3b..525c7cf6d9 100644
--- a/meson.build
+++ b/meson.build
@@ -16,17 +16,17 @@ fs = import('fs')
gnome = import('gnome')
pkgconfig = import('pkgconfig')
python3 = import('python').find_installation()
-# Ensure that we're not being run from inside the gst-uninstalled env
+# Ensure that we're not being run from inside the development environment
# because that will confuse meson, and it might find the already-built
# gstreamer. It's fine if people run `ninja` as long as it doesn't run
# reconfigure because ninja doesn't care about the env.
-ensure_not_uninstalled = '''
+ensure_not_devenv = '''
import os
assert('GST_ENV' not in os.environ)
'''
-cmdres = run_command(python3, '-c', ensure_not_uninstalled, check: false)
+cmdres = run_command(python3, '-c', ensure_not_devenv, check: false)
if cmdres.returncode() != 0
- error('Do not run `ninja` or `meson` for gst-build inside the uninstalled environment, you will run into problems')
+ error('Do not run `ninja` or `meson` for gst-build inside the development environment, you will run into problems')
endif
# Install gst-indent pre-commit hook
@@ -395,7 +395,6 @@ if meson.can_run_host_binaries() and build_machine.system() == 'linux' and host_
endif
endif
-run_target('uninstalled', command : devenv_cmd)
run_target('devenv', command : devenv_cmd)
if orc_subproject.found() and orc_update_targets.length() > 0