summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSebastian Fricke <sebastian.fricke@collabora.com>2022-02-21 10:58:28 +0100
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-03-01 11:33:10 +0000
commitd97e480dfe3097e72e6e11d612c42e216b55ba97 (patch)
tree56ae1113cf6ceff3e4b6b73c9b731aa88795a904 /meson.build
parent7063aa14712e5ec42f3db1c8135833b768ff10ea (diff)
downloadgstreamer-d97e480dfe3097e72e6e11d612c42e216b55ba97.tar.gz
meson: Adjust ninja usage restriction info for devenv
The documentation within meson highlights, that `ninja` can be used without problems for any case except `ninja reconfigure`. The warning however describes to the user, that `ninja` shouldn't be used at all. Fix the warning. Fixes: 01eb252f678 Don't allow people to run meson inside the uninstalled env Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1743>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 525c7cf6d9..6d363fd6e7 100644
--- a/meson.build
+++ b/meson.build
@@ -26,7 +26,7 @@ assert('GST_ENV' not in os.environ)
'''
cmdres = run_command(python3, '-c', ensure_not_devenv, check: false)
if cmdres.returncode() != 0
- error('Do not run `ninja` or `meson` for gst-build inside the development environment, you will run into problems')
+ error('Do not run `ninja reconfigure` or `meson` for gst-build inside the development environment, you will run into problems')
endif
# Install gst-indent pre-commit hook