summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2022-04-06 19:22:44 +1000
committerMatthew Waters <matthew@centricular.com>2022-04-07 08:17:35 +1000
commitbd5d24822a73b84a736ac362cbf68494dc206058 (patch)
treeb9b518422b4f741685468ec5a09a6b65b36b8148 /meson.build
parent3e07ce64aa550c8bdbf8ae5dc11c1d58c6541b8b (diff)
downloadgstreamer-bd5d24822a73b84a736ac362cbf68494dc206058.tar.gz
build/fuzzing: integrate fuzz targets into the build system
Currently disabled but may be enabled later. Updates the existing fuzzing to use shared libraries as that's easier for meson to deal with if there is a mix of static and shared libraries on the system. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/2123>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 579fd5038e..c65934ac7f 100644
--- a/meson.build
+++ b/meson.build
@@ -436,6 +436,8 @@ devenv_cmd = [setenv, '--builddir=@0@'.format(meson.global_build_root()),
'--srcdir=@0@'.format(meson.global_source_root())]
subdir('tests')
+subdir('ci/fuzzing')
+
if meson.can_run_host_binaries() and build_machine.system() == 'linux' and host_machine.system() == 'windows'
# FIXME: Ideally we could get the wrapper directly from meson
devenv_cmd += ['--wine', host_machine.cpu_family() == 'x86_64' ? 'wine64' : 'wine32']