summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStéphane Cerveau <scerveau@collabora.com>2022-03-31 11:45:13 +0200
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-04-06 18:12:51 +0000
commit3e07ce64aa550c8bdbf8ae5dc11c1d58c6541b8b (patch)
treeb2fde5e2dcaab2e35e730744391362d73638b61d /meson.build
parentc39181903ee33fc7d744d6d0df09815f6db9e2d1 (diff)
downloadgstreamer-3e07ce64aa550c8bdbf8ae5dc11c1d58c6541b8b.tar.gz
meson: add the list of tools to summary
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/2078>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 13 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b1b906acd6..579fd5038e 100644
--- a/meson.build
+++ b/meson.build
@@ -162,7 +162,9 @@ foreach sp : subprojects
plugins = subproj.get_variable('plugins', [])
all_plugins += plugins
all_libraries += subproj.get_variable('libraries', [])
- all_tools += subproj.get_variable('gst_tools', {})
+ if not get_option('tools').disabled()
+ all_tools += subproj.get_variable('gst_tools', {})
+ endif
orc_update_targets += subproj.get_variable('orc_update_targets', [])
@@ -464,5 +466,14 @@ if dotnet_format.found()
endif
summary({
- 'gstreamer-full': building_full,
+ 'gstreamer-full library': building_full,
}, section: 'Build options', bool_yn: true, list_sep: ' ')
+
+gst_tools = []
+foreach tool, data: all_tools
+ gst_tools += tool
+endforeach
+
+summary({
+ 'Tools': gst_tools,
+}, section: 'Build options', list_sep: ', ')