summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-10-08 20:55:08 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-10-08 20:55:08 +0100
commitf7495048480a2927fd4b203ef32b39da8dafe051 (patch)
tree359f4a3e07692143cf9dbc9ef4d377157d83d291 /meson.build
parent50311411f4b821d3f40b4ecb7801aa2860eabb73 (diff)
downloadgst-libav-f7495048480a2927fd4b203ef32b39da8dafe051.tar.gz
meson: use new 'python' module instead of deprecated 'python3' one
https://github.com/mesonbuild/meson/pull/4169
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 837a61e..2313358 100644
--- a/meson.build
+++ b/meson.build
@@ -182,5 +182,5 @@ configinc = include_directories('.')
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
subdir('ext/libav/')
-python3 = import('python3').find_python()
+python3 = import('python').find_installation()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')