summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-10-01 16:13:29 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-10-01 16:13:29 +0530
commit50311411f4b821d3f40b4ecb7801aa2860eabb73 (patch)
treee79a870ce51e568cfbddc98eacbf8ccf82812fee /meson.build
parent46cc79c43a95108967ffa041145b8117b5e49589 (diff)
downloadgst-libav-50311411f4b821d3f40b4ecb7801aa2860eabb73.tar.gz
meson: Don't export symbols from linked static libraries
We don't want to export any symbols from the ffmpeg static libraries we link to when building inside Cerbero. In the Autotools build, we pass -export-symbols-regex to libtool which ensures this for us.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d99d0ff..837a61e 100644
--- a/meson.build
+++ b/meson.build
@@ -118,6 +118,11 @@ if cc.has_argument('-fvisibility=hidden')
add_project_arguments('-fvisibility=hidden', language: 'c')
endif
+# Don't export any symbols from static ffmpeg libraries
+if cc.has_link_argument('-Wl,--exclude-libs=ALL')
+ add_project_link_arguments('-Wl,--exclude-libs=ALL', language: 'c')
+endif
+
# Disable strict aliasing
if cc.has_argument('-fno-strict-aliasing')
add_project_arguments('-fno-strict-aliasing', language: 'c')