summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-07-07 11:59:41 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-07-07 11:59:41 +0100
commiteb2f674abba1cb9e4c7601b6b360cc04c3f06fe5 (patch)
tree8b5986ea7a8f52ac96b345e4f0537be101cdf83a /meson.build
parentab42a51ae23dbb4a4b7ff3acaea0b7355f5c7b21 (diff)
downloadgst-libav-eb2f674abba1cb9e4c7601b6b360cc04c3f06fe5.tar.gz
meson: find python3 via python3 module
https://bugzilla.gnome.org/show_bug.cgi?id=783198
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 32cc028..dfb23d1 100644
--- a/meson.build
+++ b/meson.build
@@ -119,5 +119,5 @@ configinc = include_directories('.')
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
subdir('ext/libav/')
-python3 = find_program('python3')
+python3 = import('python3').find_python()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')