summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-06-26 09:53:46 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-06-26 09:53:46 +0100
commitab42a51ae23dbb4a4b7ff3acaea0b7355f5c7b21 (patch)
treeb8d5d1415bd736d724b7ca9515f2b9f4d8c02860 /meson.build
parent691c527edb264ece253ebe93bd848076d2bc2d5e (diff)
downloadgst-libav-ab42a51ae23dbb4a4b7ff3acaea0b7355f5c7b21.tar.gz
meson: fix with-package-name option
https://bugzilla.gnome.org/show_bug.cgi?id=784082
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 96c29d9..32cc028 100644
--- a/meson.build
+++ b/meson.build
@@ -40,13 +40,14 @@ cdata.set('PACKAGE', '"gst-libav"')
gst_package_name = get_option('with-package-name')
if gst_package_name == ''
if gst_version_nano == 0
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer FFMPEG Plug-ins source release')
+ gst_package_name = 'GStreamer FFMPEG Plug-ins source release'
elif gst_version_nano == 1
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer FFMPEG Plug-ins git')
+ gst_package_name = 'GStreamer FFMPEG Plug-ins git'
else
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer FFMPEG Plug-ins prerelease')
+ gst_package_name = 'GStreamer FFMPEG Plug-ins prerelease'
endif
endif
+cdata.set_quoted('GST_PACKAGE_NAME', gst_package_name)
cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))