summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-10-09 18:07:09 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-10-09 18:14:23 +0530
commit26585686b0164464a36ab11dded4f9ffb93bdcd9 (patch)
treeab68d02583e263a01c4ffece5bb68b5f4fbefe0d /meson.build
parentf7495048480a2927fd4b203ef32b39da8dafe051 (diff)
downloadgst-libav-26585686b0164464a36ab11dded4f9ffb93bdcd9.tar.gz
meson: Generate a pkgconfig file for gstlibav
This matches all other plugins in the other gstreamer repos. This is also necessary for generating the correct libtool archive (.la) files in Cerbero which are needed for static linking on Android and iOS.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2313358..35dc64b 100644
--- a/meson.build
+++ b/meson.build
@@ -180,7 +180,13 @@ endforeach
configinc = include_directories('.')
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
-subdir('ext/libav/')
+pkgconfig = import('pkgconfig')
+plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')
+if get_option('default_library') == 'shared'
+ # If we don't build static plugins there is no need to generate pc files
+ plugins_pkgconfig_install_dir = disabler()
+endif
+subdir('ext/libav')
python3 = import('python').find_installation()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')