summaryrefslogtreecommitdiff
path: root/tests/slow/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2018-07-01 21:03:28 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2018-07-02 06:42:30 +0200
commita67b067e95267b763e8c8d562afa13a65651fe5a (patch)
treeb3b106b451239a8eb766b095624ec548168ca7ce /tests/slow/Makefile.am
parent58552a26672448c92061542ec93f161fd257f508 (diff)
downloadgnutls-tmp-cipher-codes.tar.gz
tests: introduced tests about crypto API failures on illegal usetmp-cipher-codes
This ensures that any mistakes in using the crypto API are propagated to the higher level calls, or result to an abort(). Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'tests/slow/Makefile.am')
-rw-r--r--tests/slow/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tests/slow/Makefile.am b/tests/slow/Makefile.am
index f387a00c7c..2672c1b2f6 100644
--- a/tests/slow/Makefile.am
+++ b/tests/slow/Makefile.am
@@ -47,9 +47,10 @@ mac_override_LDFLAGS = $(NETTLE_LIBS) $(HOGWEED_LIBS) $(GMP_LIBS) $(LDADD)
endif
-dist_check_SCRIPTS = test-ciphers.sh override-ciphers test-hash-large.sh test-ciphers-common.sh
-check_PROGRAMS = $(ctests) cipher-test cipher-override mac-override cipher-override2 hash-large crypto
-TESTS = $(ctests) test-ciphers.sh override-ciphers test-hash-large.sh crypto
+dist_check_SCRIPTS = test-ciphers.sh override-ciphers test-hash-large.sh test-ciphers-common.sh \
+ test-ciphers-api.sh
+check_PROGRAMS = $(ctests) cipher-test cipher-api-test cipher-override mac-override cipher-override2 hash-large crypto
+TESTS = $(ctests) test-ciphers.sh override-ciphers test-hash-large.sh crypto test-ciphers-api.sh
if HAVE_LIBCRYPTO
cipher_openssl_compat_LDFLAGS = $(LDADD) $(LIBCRYPTO)