summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-06-02 12:23:57 +0200
committerBastien Nocera <hadess@hadess.net>2021-06-02 13:28:59 +0200
commitab1d1ef432d4610d14d4de8b24773b99d2f68b21 (patch)
treeedc7623e2d0ed03775147244caf180025f0a5923 /meson.build
parent6eed43fbab7e5aad2ae4d7e63b412add180ed9af (diff)
downloadgupnp-ab1d1ef432d4610d14d4de8b24773b99d2f68b21.tar.gz
Throw a compilation error for too new glib features
Throw a compilation error if a "deprecated" function is used, such as when using functionality that's only available in newer versions than the minimum one required.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index aba8c93..63b0f36 100644
--- a/meson.build
+++ b/meson.build
@@ -13,6 +13,7 @@ conf.set('HAVE_NETLINK', netlink_available)
conf.set('HAVE_IFADDRS_H', ifaddrs_available)
conf.set('HAVE_LINUX_WIRELESS_H', cc.has_header('linux/wireless.h'))
+add_project_arguments(cc.get_supported_arguments('-Werror=deprecated-declarations'), language: 'c')
conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_58')
conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_2_58')