summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-06-02 12:16:17 +0200
committerBastien Nocera <hadess@hadess.net>2021-06-02 13:28:31 +0200
commit6eed43fbab7e5aad2ae4d7e63b412add180ed9af (patch)
tree342cdd64c2ac73e11474c5c2a21e15be3bb7bf45 /meson.build
parent330d6e6009b1838ae4df2c6534a58bbea41fd39a (diff)
downloadgupnp-6eed43fbab7e5aad2ae4d7e63b412add180ed9af.tar.gz
Pin the required glib version
Now that all the sources import a config.h, set the maximum version of glib to be used to the currently minimum required one.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b395086..aba8c93 100644
--- a/meson.build
+++ b/meson.build
@@ -13,6 +13,9 @@ conf.set('HAVE_NETLINK', netlink_available)
conf.set('HAVE_IFADDRS_H', ifaddrs_available)
conf.set('HAVE_LINUX_WIRELESS_H', cc.has_header('linux/wireless.h'))
+conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_58')
+conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_2_58')
+
config_h = configure_file(output : 'config.h', configuration : conf)
add_project_arguments('-DHAVE_CONFIG_H=1', language : 'c')