summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2021-06-02 13:39:25 +0200
committerJens Georg <mail@jensge.org>2021-06-02 13:39:25 +0200
commit882c99ec0786367d457a733b189293ad5cab4314 (patch)
treedbf743fa7f91a4be75b69abc4bc604cacbda2cec /meson.build
parentab1d1ef432d4610d14d4de8b24773b99d2f68b21 (diff)
downloadgupnp-882c99ec0786367d457a733b189293ad5cab4314.tar.gz
build: Bump GLib version to 2.66.
Also parameterize it so it is consistent
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 7 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 63b0f36..27ddf2b 100644
--- a/meson.build
+++ b/meson.build
@@ -13,9 +13,10 @@ conf.set('HAVE_NETLINK', netlink_available)
conf.set('HAVE_IFADDRS_H', ifaddrs_available)
conf.set('HAVE_LINUX_WIRELESS_H', cc.has_header('linux/wireless.h'))
+glib_version = '2.66'
add_project_arguments(cc.get_supported_arguments('-Werror=deprecated-declarations'), language: 'c')
-conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_58')
-conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_2_58')
+conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_' + glib_version.underscorify())
+conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_' + glib_version.underscorify())
config_h = configure_file(output : 'config.h', configuration : conf)
add_project_arguments('-DHAVE_CONFIG_H=1', language : 'c')
@@ -25,10 +26,10 @@ guul = subproject('guul', default_options : ['default_library=static'])
gssdp_dep = dependency('gssdp-1.2', version : '>= 1.2.3', default_options: ['sniffer=false'])
dependencies = [
- dependency('glib-2.0', version : '>= 2.58'),
- dependency('gio-2.0', version : '>= 2.58'),
- dependency('gmodule-2.0', version : '>= 2.44'),
- dependency('gobject-2.0', version : '>= 2.44'),
+ dependency('glib-2.0', version : '>= ' + glib_version),
+ dependency('gio-2.0', version : '>= ' + glib_version),
+ dependency('gmodule-2.0', version : '>= ' + glib_version),
+ dependency('gobject-2.0', version : '>= ' + glib_version),
dependency('libsoup-2.4', version : '>= 2.48.0'),
gssdp_dep,
dependency('libxml-2.0')