summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJay Faulkner <jay@jvf.cc>2022-04-16 18:12:53 -0700
committerNiels De Graef <nielsdegraef@gmail.com>2022-05-13 09:35:52 +0000
commitdd49ab586158a6298134cea42df64581586d3747 (patch)
treed520fe1e02e85958b5a3941ba80390cb8df3d8a7 /meson.build
parentd37684f831c22b706add943c7ccf987b8c7101af (diff)
downloadgnome-contacts-dd49ab586158a6298134cea42df64581586d3747.tar.gz
Fix build failures with vala <0.54
gnome-contacts 42.0 fails to build with earlier versions of vala with "error: `GLib.GenericArray<Contacts.VcardTypeMapping?>' does not have an `iterator' method". See https://bugs.gentoo.org/838727 for additional information.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 75cbdde..82a86b2 100644
--- a/meson.build
+++ b/meson.build
@@ -33,7 +33,7 @@ min_folks_version = '0.14'
min_glib_version = '2.58' # We also use this value for --target-glib, so scratch the micro version.
# We know that compiling on a lower version doesn't work
-min_vala_version = '0.40.10'
+min_vala_version = '0.54.0'
if valac.version().version_compare('<' + min_vala_version)
error('Your Vala installation is too old (@0@).'.format(valac.version())
+ ' Please make sure you have at least Vala ' + min_vala_version)