summaryrefslogtreecommitdiff
path: root/sendto/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-21 11:32:56 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-11 12:17:33 +0100
commit83c6246b3f4933f81d4fafb4b4f8ca139dc569e2 (patch)
tree47ee2125b5f3468a00d61f48bbd7d9f169dfa845 /sendto/meson.build
parentc84f5d8c2b9521e1d397b08f8293024a7ba14965 (diff)
downloadgnome-bluetooth-83c6246b3f4933f81d4fafb4b4f8ca139dc569e2.tar.gz
build: Fix dependencies
libgnome-bluetooth expose a number of includes in their public headers belonging to different libraries. Therefore, these libraries are indirect dependencies of the library to be built. With this in mind, required dependencies have been split in two sets, one formed by public dependencies and the other by private dependencies. The created `pkg-config` file now also use these new sets.
Diffstat (limited to 'sendto/meson.build')
-rw-r--r--sendto/meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/sendto/meson.build b/sendto/meson.build
index f0e8ad8f..d7604e97 100644
--- a/sendto/meson.build
+++ b/sendto/meson.build
@@ -3,12 +3,8 @@ name = 'bluetooth-sendto'
executable(
name,
'main.c',
- include_directories: [
- top_inc,
- lib_inc,
- ],
- dependencies: gtk_dep,
- link_with: libgnome_bluetooth,
+ include_directories: top_inc,
+ dependencies: libgnome_bluetooth_dep,
install: true,
)