summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-14 09:59:24 +0100
committerBastien Nocera <hadess@hadess.net>2017-11-15 13:47:53 +0100
commitb029fbe1ac0716163193a7e896a84e0f08bbcfdf (patch)
tree519916eb6b7e8f4d724d5805f04870c7ddaa877b /meson.build
parent2739f5ce691eae31eb2c2680d6a90019c7b6d287 (diff)
downloadgnome-bluetooth-b029fbe1ac0716163193a7e896a84e0f08bbcfdf.tar.gz
build: Rename build options
Following the new meson porting guidelines, this patch renames the build options as follows: - Remove the 'enable' prefix from boolean options. - Remove the 'with' prefix from string options. - The character separator in multi-word options has been changed to underscore. https://bugzilla.gnome.org/show_bug.cgi?id=790332
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 87a9ca02..ead22064 100644
--- a/meson.build
+++ b/meson.build
@@ -41,8 +41,8 @@ gnomebt_buildtype = get_option('buildtype')
gnomebt_debug = gnomebt_buildtype.contains('debug')
# options
-enable_gtk_doc = get_option('enable-gtk-doc')
-enable_gir = get_option('enable-introspection')
+enable_gtk_doc = get_option('gtk_doc')
+enable_gir = get_option('introspection')
# Before making a release, the GNOMEBT_LT_VERSION string should be modified.
# The string is of the form C:R:A.
@@ -175,7 +175,7 @@ endif
subdir('po')
-meson.add_install_script('meson_post_install.py', get_option('enable-icon-update') ? 'icon-update' : '')
+meson.add_install_script('meson_post_install.py', get_option('icon_update') ? 'icon_update' : '')
output = '\nConfigure summary:\n\n'
output += ' Compiler....................: ' + cc.get_id() + '\n\n'