summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2018-07-27 14:43:18 +0200
committerBastien Nocera <hadess@hadess.net>2018-07-27 14:44:53 +0200
commit42a2338bfe23ed3d9cc0da90850f5c8f4c7162d5 (patch)
tree7ab8d6ab99c0932f3d34ace8dcbe5b6e5291feec /meson.build
parentb0a30ecef015a2ac2b612bcd4f46e2f215a83ee2 (diff)
downloadgnome-bluetooth-42a2338bfe23ed3d9cc0da90850f5c8f4c7162d5.tar.gz
build: Move all dependency() statements to top-level
So we know what we need to build gnome-bluetooth without looking in sub-directories.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e5fbff4b..88c32a0c 100644
--- a/meson.build
+++ b/meson.build
@@ -99,6 +99,12 @@ add_project_arguments(common_flags + compiler_flags, language: 'c')
gtk_dep = dependency('gtk+-3.0', version: '>= 3.12.0')
m_dep = cc.find_library('m')
+libgbt_dep = [ dependency('gio-unix-2.0'),
+ dependency('gmodule-2.0'),
+ dependency('libcanberra-gtk3'),
+ dependency('libnotify', version: '>= 0.7.0'),
+ dependency('libudev')
+]
gnome = import('gnome')
i18n = import('i18n')